A recent incident in the Singapore region is under investigation
Incident Report for Ringotel
Postmortem

Our team has found the root cause of the issue and has implemented measures to mitigate such situations in the future. We also additionally increased infrastructure capacity in the region.

Posted Apr 17, 2024 - 19:34 UTC

Resolved
We are investigating the root cause of the incident in the Singapore region that occurred on April 14.
Posted Apr 14, 2024 - 06:30 UTC